Link `/share/xdg-desktop-portal` to environment to ensure packages installed via user packages in home-manager work correctly.
14 lines
299 B
Nix
14 lines
299 B
Nix
{ pkgs, lib, ... }:
|
|
{
|
|
services.greetd = {
|
|
enable = true;
|
|
settings = {
|
|
default_session.command = "${lib.getExe pkgs.greetd.tuigreet} --cmd wayland-session";
|
|
};
|
|
};
|
|
|
|
security.pam.services.swaylock = { };
|
|
|
|
environment.pathsToLink = lib.singleton "/share/xdg-desktop-portal";
|
|
}
|