nix-exprs/flake/outputs/devshell.nix
2024-11-25 18:34:12 +08:00

21 lines
350 B
Nix

{
perSystem =
{
config,
pkgs,
lib,
...
}:
{
devshells.default = {
packages = with pkgs; [
just
];
env = [
(lib.nameValuePair "DEVSHELL_NO_MOTD" 1)
];
devshell.startup.pre-commit-hook.text = config.pre-commit.installationScript;
};
};
}